summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-05-28 15:19:17 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-06-06 21:09:51 +0200
commit7f1620df1441d976d737785310fcd9a02c6b5bce (patch)
tree964d81de128e32a831d87d45df8b13a89a80c073 /gnu/packages/ocaml.scm
parent4a5fd872032f8ed4c576fa8f04984b9fea012b9e (diff)
downloadguix-patches-7f1620df1441d976d737785310fcd9a02c6b5bce.tar
guix-patches-7f1620df1441d976d737785310fcd9a02c6b5bce.tar.gz
gnu: Add ocaml-async-unix.
* gnu/packages/ocaml.scm (ocaml-async-unix): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 1a70b67bfb..a40ebea545 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3001,3 +3001,24 @@ the Async RPC library.")
(description "The Core suite of libraries is an alternative to OCaml's
standard library that was developed by Jane Street.")
(license license:asl2.0)))
+
+(define-public ocaml-async-unix
+ (package
+ (name "ocaml-async-unix")
+ (version "113.33.03")
+ (source (janestreet-origin "async_unix" version
+ "1fwl0lfrizllcfjk8hk8m7lsz9ha2jg6qgk4gssfyz377qvpcq4h"))
+ (native-inputs
+ `(("oasis" ,ocaml-oasis)
+ ("js-build-tools" ,ocaml-js-build-tools)
+ ("ppx-jane" ,ocaml-ppx-jane)
+ ("opam" ,opam)))
+ (propagated-inputs
+ `(("async-kernel" ,ocaml-async-kernel)
+ ("core" ,ocaml-core)))
+ (build-system ocaml-build-system)
+ (arguments janestreet-arguments)
+ (home-page "https://github.com/janestreet/async_unix")
+ (synopsis "Asynchronous execution library for Unix")
+ (description "Async_unix is an asynchronous execution library for Unix.")
+ (license license:asl2.0)))