summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-01-02 12:42:29 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-31 21:35:30 +0100
commit0e9e94b7ffe25d11c55f79f7c08a4bc69df95632 (patch)
treef0bfad4e9ae4648d3bd94d3081404edf40b2b2c5 /gnu/packages/ocaml.scm
parent41e8e07919f844bf83e5ae3ca6cd0cbaa760e1c8 (diff)
downloadguix-patches-0e9e94b7ffe25d11c55f79f7c08a4bc69df95632.tar
guix-patches-0e9e94b7ffe25d11c55f79f7c08a4bc69df95632.tar.gz
gnu: Add ocaml-batteries.
* gnu/packages/ocaml.scm (ocaml-batteries): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2ba9a7e0b9..a904a86b0d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1796,3 +1796,32 @@ many additional enhancements, including:
license:expat ; OMake scripts
license:gpl2)))) ; OMake itself, with ocaml linking exception
; see LICENSE.OMake
+
+(define-public ocaml-batteries
+ (package
+ (name "ocaml-batteries")
+ (version "2.5.3")
+ (source (origin
+ (method url-fetch)
+ (uri (ocaml-forge-uri "batteries" version 1650))
+ (sha256
+ (base32
+ "1a97w3x2l1jr5x9kj5gqm1x6b0q9fjqdcsvls7arnl3bvzgsia0n"))))
+ (build-system ocaml-build-system)
+ (native-inputs
+ `(("qtest" ,ocaml-qtest)
+ ("bisect" ,ocaml-bisect)
+ ("ounit" ,ocaml-ounit)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'check) ; tests are run by the build phase
+ (replace 'build
+ (lambda* (#:key outputs #:allow-other-keys)
+ (zero? (system* "ocaml" "setup.ml" "-build")))))))
+ (home-page "http://batteries.forge.ocamlcore.org/")
+ (synopsis "Development platform for the OCaml programming language")
+ (description "Define a standard set of libraries which may be expected on
+every compliant installation of OCaml and organize these libraries into a
+hierarchy of modules.")
+ (license license:lgpl2.1+)))