summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:23:12 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-13 17:15:29 +0200
commit90db0c0f17ade7d211225548726fdadbe4431a60 (patch)
tree398406902ea7f6e3d5fe81fd8a5584c98e650229 /gnu/packages/ocaml.scm
parenta6bd051c04b8a643b9811afcc04fb8416366b256 (diff)
downloadguix-patches-90db0c0f17ade7d211225548726fdadbe4431a60.tar
guix-patches-90db0c0f17ade7d211225548726fdadbe4431a60.tar.gz
gnu: Add ocaml-ppx-optcomp
* gnu/packages/ocaml.scm (ocaml-ppx-optcomp): New variable. (ocaml4.07-ppx-optcomp): Inherit from ocaml-ppx-optcomp. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm52
1 files changed, 31 insertions, 21 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ac6b646d46..e282edc396 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -5582,35 +5582,45 @@ context such as function arguments.")
else expression.")
(license license:asl2.0)))
-(define-public ocaml4.07-ppx-optcomp
+(define-public ocaml-ppx-optcomp
(package
- (name "ocaml4.07-ppx-optcomp")
- (version "0.11.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://ocaml.janestreet.com/ocaml-core/v"
- (version-major+minor version)
- "/files/ppx_optcomp-v" version ".tar.gz"))
- (sha256
- (base32
- "1bb52p2j2h4s9f06vrcpla80rj93jinnzq6jzilapyx9q068929i"))))
+ (name "ocaml-ppx-optcomp")
+ (version "0.14.1")
+ (home-page "https://github.com/janestreet/ppx_optcomp")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0j5smqa0hig1yn8wfrb4mv0y59kkwsalmqkm5asbd7kcc6589ap4"))))
(build-system dune-build-system)
- (arguments
- `(#:ocaml ,ocaml-4.07
- #:findlib ,ocaml4.07-findlib
- #:dune ,ocaml4.07-dune))
(propagated-inputs
- `(("ocaml-base" ,(package-with-ocaml4.07 ocaml-base))
- ("ocaml-stdio" ,(package-with-ocaml4.07 ocaml-stdio))
- ("ocaml-ppxlib" ,(package-with-ocaml4.07 ocaml-ppxlib))))
- (properties `((upstream-name . "ppx_optcomp")))
- (home-page "https://github.com/janestreet/ppx_optcomp")
+ `(("ocaml-base" ,ocaml-base)
+ ("ocaml-stdio" ,ocaml-stdio)
+ ("ocaml-ppxlib" ,ocaml-ppxlib)))
+ (properties `((upstream-name . "ppx_optcomp")
+ (ocaml4.07-variant . ,(delay ocaml4.07-ppx-optcomp))))
(synopsis "Optional compilation for OCaml")
(description "Ppx_optcomp stands for Optional Compilation. It is a tool
used to handle optional compilations of pieces of code depending of the word
size, the version of the compiler, ...")
(license license:asl2.0)))
+(define-public ocaml4.07-ppx-optcomp
+ (package-with-ocaml4.07
+ (package
+ (inherit ocaml-ppx-optcomp)
+ (version "0.11.0")
+ (source
+ (janestreet-origin
+ "ppx_optcomp" version
+ "1bb52p2j2h4s9f06vrcpla80rj93jinnzq6jzilapyx9q068929i"))
+ (properties `((upstream-name . "ppx_optcomp"))))))
+
(define-public ocaml-ppx-let
(package
(name "ocaml-ppx-let")
@@ -5956,7 +5966,7 @@ functions from type definitions.")
("ocaml-ppx-here" ,(package-with-ocaml4.07 ocaml-ppx-here))
("ocaml-ppx-inline-test" ,ocaml4.07-ppx-inline-test)
("ocaml-ppx-let" ,(package-with-ocaml4.07 ocaml-ppx-let))
- ("ocaml-ppx-optcomp" ,ocaml4.07-ppx-optcomp)
+ ("ocaml-ppx-optcomp" ,(package-with-ocaml4.07 ocaml-ppx-optcomp))
("ocaml-ppx-optional" ,ocaml4.07-ppx-optional)
("ocaml-ppx-pipebang" ,ocaml4.07-ppx-pipebang)
("ocaml-ppx-sexp-message" ,ocaml4.07-ppx-sexp-message)