summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorGabriel Hondet <gabrielhondet@gmail.com>2019-02-01 09:49:20 +0100
committerJulien Lepiller <julien@lepiller.eu>2019-02-04 22:03:27 +0100
commitb2c2c415c53d0747ca62a4807264f182d97b8382 (patch)
tree88ba6d99bfd2348adfe01d08a9032e5632e8fcf5 /gnu/packages/ocaml.scm
parent625a3daa12217d7cd162149dcba5657237bb9455 (diff)
downloadguix-patches-b2c2c415c53d0747ca62a4807264f182d97b8382.tar
guix-patches-b2c2c415c53d0747ca62a4807264f182d97b8382.tar.gz
gnu: ocaml-migrate-parsetree: Update to 1.2.0.
* gnu/packages/ocaml.scm (ocaml-migrate-parsetree): Update to 1.2.0. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 986e435f48..a1f9e7996b 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1419,24 +1419,24 @@ following a very simple s-expression syntax.")
(define-public ocaml-migrate-parsetree
(package
(name "ocaml-migrate-parsetree")
- (version "1.1.0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/ocaml-ppx/"
- "ocaml-migrate-parsetree/releases/download/v"
- version "/ocaml-migrate-parsetree-"
- version ".tbz"))
- (sha256
- (base32
- "01zjp1q4hryqaxv4apkjd868fycz2kf887r6lkb6x2a545h1lh7f"))))
+ (version "1.2.0")
+ (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append home-page ".git"))
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "16kas19iwm4afijv3yxd250s08absabmdcb4yj57wc8r4fmzv5dm"))))
(build-system dune-build-system)
(arguments
- `(#:tests? #f
- #:jbuild? #t))
+ `(#:tests? #f))
(propagated-inputs
- `(("ocamlbuild" ,ocamlbuild)
+ `(("ocaml-ppx-derivers" ,ocaml-ppx-derivers)
+ ("ocamlbuild" ,ocamlbuild)
("ocaml-result" ,ocaml-result)))
- (home-page "https://github.com/ocaml-ppx/ocaml-migrate-parsetree")
(synopsis "OCaml parsetree convertor")
(description "This library converts between parsetrees of different OCaml
versions. For each version, there is a snapshot of the parsetree and conversion