summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:46:33 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-16 22:34:39 +0100
commitf46bceb6708d76fc748e2d208c73ab8584b81504 (patch)
tree3e0cf4dd68d88d54bf2c522561d35484043c5923 /gnu/packages/ocaml.scm
parentbeeb2d419b23d941c58c5a653ab9fe5c14247cef (diff)
downloadguix-patches-f46bceb6708d76fc748e2d208c73ab8584b81504.tar
guix-patches-f46bceb6708d76fc748e2d208c73ab8584b81504.tar.gz
gnu: Add ocaml-astring.
* gnu/packages/ocaml.scm (ocaml-astring): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index ace8424a9d..096c3f1894 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1255,3 +1255,33 @@ most of the POSIX and GNU conventions.")
(description "Fmt exposes combinators to devise Format pretty-printing
functions.")
(license license:isc)))
+
+(define-public ocaml-astring
+ (package
+ (name "ocaml-astring")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/astring/releases/astring-"
+ version ".tbz"))
+ (sha256 (base32
+ "0ixjwc3plrljvj24za3l9gy0w30lsbggp8yh02lwrzw61ls4cri0"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("opam" ,opam)
+ ("topkg" ,ocaml-topkg)))
+ (arguments `(#:tests? #f
+ #:build-flags (list "build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/astring")
+ (synopsis "Alternative String module for OCaml")
+ (description "Astring exposes an alternative String module for OCaml. This
+module balances minimality and expressiveness for basic, index-free, string
+processing and provides types and functions for substrings, string sets and
+string maps. The String module exposed by Astring has exception safe functions,
+removes deprecated and rarely used functions, alters some signatures and names,
+adds a few missing functions and fully exploits OCaml's newfound string
+immutability.")
+ (license license:isc)))