summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:24:17 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:20:55 +0100
commit33f16b9a576a661fb4958bb0011ef67ad634d21b (patch)
treeedfec50793dee2fd24156ffd99fa9413191ac8af /gnu/packages/ocaml.scm
parent6e9b678efe7f96e8087da1aab9619e708e4e3dba (diff)
downloadguix-patches-33f16b9a576a661fb4958bb0011ef67ad634d21b.tar
guix-patches-33f16b9a576a661fb4958bb0011ef67ad634d21b.tar.gz
gnu: Add ocaml-uchar.
* gnu/packages/ocaml.scm (ocaml-uchar): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5488308ede..418670df2f 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1586,3 +1586,27 @@ representation of the data.")
(synopsis "Lexer generator for Unicode and OCaml")
(description "Lexer generator for Unicode and OCaml.")
(license license:expat)))
+
+(define-public ocaml-uchar
+ (package
+ (name "ocaml-uchar")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ocaml/uchar/releases/download/v"
+ version "/uchar-" version ".tbz"))
+ (sha256 (base32
+ "0ficw1x7ymbd6m8hqw3w1aycwm1hbwd6bad3c5pspwnzh3qlikhi"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:build-flags (list "native=true" "native-dynlink=true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs `(("opam" ,opam)))
+ (home-page "https://github.com/ocaml/uchar")
+ (synopsis "Compatibility library for OCaml's Uchar module")
+ (description "The uchar package provides a compatibility library for the
+`Uchar` module introduced in OCaml 4.03.")
+ (license license:lgpl2.1)))