summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 11:51:50 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-16 22:34:48 +0100
commit1342fce1025eb3c9afca945f92ea05003a272434 (patch)
tree4e6cbe217d49894142d7287fc0c1df6209368457 /gnu/packages/ocaml.scm
parent0a7b43a8187f8f374ab1a696fedf182679a5ae65 (diff)
downloadguix-patches-1342fce1025eb3c9afca945f92ea05003a272434.tar
guix-patches-1342fce1025eb3c9afca945f92ea05003a272434.tar.gz
gnu: Add ocaml-react.
* gnu/packages/ocaml.scm (ocaml-react): New variable.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 16d56febd1..1fb2ccfb57 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1335,3 +1335,29 @@ simple (yet expressive) query language to select the tests to run.")
(synopsis "Tools for authors of ppx rewriters and other syntactic tools")
(description "Tools for authors of ppx rewriters and other syntactic tools.")
(license license:expat)))
+
+(define-public ocaml-react
+ (package
+ (name "ocaml-react")
+ (version "1.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/react/releases/react-"
+ version ".tbz"))
+ (sha256 (base32
+ "0knhgbngphv5sp1yskfd97crf169qhpc0igr6w7vqw0q36lswyl8"))))
+ (build-system ocaml-build-system)
+ (native-inputs `(("opam" ,opam)))
+ (arguments `(#:tests? #f
+ #:build-flags (list "native=true" "native-dynlink=true")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://erratique.ch/software/react")
+ (synopsis "Declarative events and signals for OCaml")
+ (description "React is an OCaml module for functional reactive programming
+(FRP). It provides support to program with time varying values: declarative
+events and signals. React doesn't define any primitive event or signal, it
+lets the client choose the concrete timeline.")
+ (license license:bsd-3)))