summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:22:44 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:15:58 +0200
commitb477a9f42e52cf07e05add0632bc01e9d268dd55 (patch)
tree72656721bdbf4889b3d897121c259cb30459e899 /gnu/packages/ocaml.scm
parentb2122b07dc24007263b92247cc479713c2101390 (diff)
downloadguix-patches-b477a9f42e52cf07e05add0632bc01e9d268dd55.tar
guix-patches-b477a9f42e52cf07e05add0632bc01e9d268dd55.tar.gz
gnu: ocaml-integers: Update to 0.4.0.
* gnu/packages/ocaml.scm (ocaml-integers): Update to 0.4.0. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm29
1 files changed, 10 insertions, 19 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 272f5bf268..b297a5202e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 divoplade <d@divoplade.fr>
-;;; Copyright © 2020 pukkamustard <pukkamustard@posteo.net>
+;;; Copyright © 2020, 2021 pukkamustard <pukkamustard@posteo.net>
;;; Copyright © 2021 aecepoglu <aecepoglu@fastmail.fm>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
@@ -3809,29 +3809,20 @@ sensitive completion, colors, and more.")
(define-public ocaml-integers
(package
(name "ocaml-integers")
- (version "0.3.0")
+ (version "0.4.0")
(home-page "https://github.com/ocamllabs/ocaml-integers")
(source (origin
- (method url-fetch)
- (uri (string-append home-page
- "/releases/download/v0.2.2/integers-"
- version ".tbz"))
- (file-name (string-append name "-" version ".tbz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "08b1ljw88ny3l0mdq6xmffjk8anfc77igryva5jz1p6f4f746ywk"))))
- (build-system ocaml-build-system)
+ "0yp3ab0ph7mp5741g7333x4nx8djjvxzpnv3zvsndyzcycspn9dd"))))
+ (build-system dune-build-system)
(arguments
- `(#:tests? #f; no tests
- #:build-flags (list "build")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
- (native-inputs
- `(("ocamlbuild" ,ocamlbuild)))
- (inputs
- `(("topkg" ,ocaml-topkg)
- ("opam" ,opam)))
+ `(#:tests? #f)) ; no tests
(synopsis "Various signed and unsigned integer types for OCaml")
(description "The ocaml-integers library provides a number of 8-, 16-, 32-
and 64-bit signed and unsigned integer types, together with aliases such as