summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorpukkamustard <pukkamustard@posteo.net>2021-06-01 20:22:47 +0000
committerJulien Lepiller <julien@lepiller.eu>2021-06-06 17:16:25 +0200
commit0f5f8d48f8aadf3778cd967c522c06352f260c21 (patch)
tree86f8efb8647445af04854c5ef27476f309c9a776 /gnu/packages/ocaml.scm
parent5a4acc53311c7013a2afeb5ce7460e2aa24a4c2b (diff)
downloadguix-patches-0f5f8d48f8aadf3778cd967c522c06352f260c21.tar
guix-patches-0f5f8d48f8aadf3778cd967c522c06352f260c21.tar.gz
gnu: ocaml-lwt: Make libev a propagated input.
* gnu/packages/ocaml.scm (ocaml-lwt) [propagated-inputs]: Add libev. [inputs]: Remove libev. (ocaml-ouint2, ocaml4.07-lambda-term, ocaml-markup) [inputs]: Remove libev. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9e163994d9..1f47eab52e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1341,9 +1341,6 @@ compilers that can directly deal with packages.")
(base32
"0gxjw1bhmjcjzri6x6psqrkbbyq678b69bqfl9i1zswp7cj2lryg"))))
(build-system dune-build-system)
- (inputs
- ;; XXX Should libev be a propagated-input of ocaml-lwt?
- `(("libev" ,libev)))
(propagated-inputs
`(("lwt" ,ocaml-lwt)
("ocaml-stdlib-shims" ,ocaml-stdlib-shims)))
@@ -2317,13 +2314,13 @@ for mapping files in memory. This function is the same as the
("ocaml-cppo" ,ocaml-cppo)
("pkg-config" ,pkg-config)))
(inputs
- `(("libev" ,libev)
- ("glib" ,glib)))
+ `(("glib" ,glib)))
(propagated-inputs
`(("ocaml-mmap" ,ocaml-mmap)
("ocaml-ocplib-endian" ,ocaml-ocplib-endian)
("ocaml-result" ,ocaml-result)
- ("ocaml-seq" ,ocaml-seq)))
+ ("ocaml-seq" ,ocaml-seq)
+ ("libev" ,libev)))
(home-page "https://github.com/ocsigen/lwt")
(synopsis "Cooperative threads and I/O in monadic style")
(description "Lwt provides typed, composable cooperative threads. These
@@ -3760,8 +3757,6 @@ connect an engine to your inputs and rendering functions to get an editor.")
("ocaml-lwt-log" ,(package-with-ocaml4.07 ocaml-lwt-log))
("ocaml-lwt-react" ,(package-with-ocaml4.07 ocaml-lwt-react))
("ocaml-zed" ,ocaml4.07-zed)))
- (inputs
- `(("libev" ,libev)))
(home-page "https://github.com/diml/lambda-term")
(synopsis "Terminal manipulation library for OCaml")
(description "Lambda-Term is a cross-platform library for manipulating the
@@ -6010,8 +6005,6 @@ the full Core is not available, such as in Javascript.")
(build-system dune-build-system)
(arguments
`(#:package "markup"))
- (inputs
- `(("libev" ,libev)))
(propagated-inputs
`(("ocaml-bisect-ppx" ,ocaml-bisect-ppx)
("ocaml-uchar" ,ocaml-uchar)