summaryrefslogtreecommitdiff
path: root/gnu/packages/ntp.scm
diff options
context:
space:
mode:
authorJean-Pierre De Jesus DIAZ <jean@foundationdevices.com>2023-08-07 14:17:49 +0200
committerLudovic Courtès <ludo@gnu.org>2023-08-12 22:30:28 +0200
commit6bbef3d9a269c38a6af941fb8f7c7b1d82834776 (patch)
tree1edc9258eb9e8084fc8fee195e93aad46302dfbd /gnu/packages/ntp.scm
parenteb25c2b3e204a36a97ec724defe8930757ab83c0 (diff)
downloadguix-patches-6bbef3d9a269c38a6af941fb8f7c7b1d82834776.tar
guix-patches-6bbef3d9a269c38a6af941fb8f7c7b1d82834776.tar.gz
gnu: ntp: Fix cross-compilation inputs.
* gnu/packages/ntp.scm (ntp)[inputs]: Use `target-linux?' instead of the manual string comparison as it would not add the libcap input correctly when cross-compiling as the platform ends in `-linux-gnu' unlike the system string which ends in `-linux'. Signed-off-by: Jean-Pierre De Jesus DIAZ <jean@foundationdevices.com> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/ntp.scm')
-rw-r--r--gnu/packages/ntp.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 1a72efbc79..4ab8ab6631 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -139,8 +139,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
libevent
;; Build with POSIX capabilities support on GNU/Linux. This allows
;; 'ntpd' to run as non-root (when invoked with '-u'.)
- (if (string-suffix? "-linux"
- (or (%current-target-system) (%current-system)))
+ (if (target-linux?)
(list libcap)
'())))
(arguments