summaryrefslogtreecommitdiff
path: root/gnu/packages/node.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-08 20:56:39 +0100
committerMarius Bakke <marius@gnu.org>2020-12-08 22:57:53 +0100
commit18f10c0b12dd369507fd2821dcf748fc9b13053a (patch)
treea4ade9ca81542bafda5b40fd044688a9be3d9137 /gnu/packages/node.scm
parent3eb34c66b42d1fa520a374e9b35a6ce7bd1e8987 (diff)
downloadguix-patches-18f10c0b12dd369507fd2821dcf748fc9b13053a.tar
guix-patches-18f10c0b12dd369507fd2821dcf748fc9b13053a.tar.gz
gnu: node: Update to 10.22.1.
This follows up on 3eb34c66b42d1fa520a374e9b35a6ce7bd1e8987 which left an unbound "nghttp2-1.41" variable. * gnu/packages/node.scm (node): Update to 10.22.1. (node-10.22): Remove variable. * gnu/packages/gnuzilla.scm (icecat)[native-inputs]: Change from NODE-10.22 to NODE. (icedove)[native-inputs]: Likewise.
Diffstat (limited to 'gnu/packages/node.scm')
-rw-r--r--gnu/packages/node.scm22
1 files changed, 2 insertions, 20 deletions
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index f04e39bbd5..66ef4f0905 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -48,14 +48,14 @@
(define-public node
(package
(name "node")
- (version "10.20.0")
+ (version "10.22.1")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "0cvjwnl0wkcsyw3kannbdv01s235wrnp11n2s6swzjx95gpichfi"))
+ "0pr569qiabr4m7k38s7rwi3iyzrc5jmx19z2z0k7n4xfvhjlfzzl"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -201,24 +201,6 @@ devices.")
(properties '((max-silent-time . 7200) ;2h, needed on ARM
(timeout . 21600))))) ;6h
-;; TODO: Make this the default node on core-updates. This cannot be done on
-;; master since this version of node requires a newer nghttp2 library at link
-;; time.
-(define-public node-10.22
- (package
- (inherit node)
- (version "10.22.1")
- (source (origin
- (inherit (package-source node))
- (uri (string-append "https://nodejs.org/dist/v" version
- "/node-v" version ".tar.xz"))
- (sha256
- (base32
- "0pr569qiabr4m7k38s7rwi3iyzrc5jmx19z2z0k7n4xfvhjlfzzl"))))
- (inputs
- (alist-replace "nghttp2" (list nghttp2-1.41 "lib")
- (package-inputs node)))))
-
(define-public libnode
(package
(inherit node)