summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/node-xyz.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 98c611f227..9a0be96852 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -118,7 +118,7 @@ architecture supporting plugins.")
;; We skip the two tests which are supposed to fail.
(invoke "bin/node-far" "-v" "test/" "-e" "test.*fail.js"))))))
(inputs
- `(("node-oop" ,node-oop)))
+ (list node-oop))
(home-page "https://github.com/felixge/node-far")
(synopsis "Node.js test runner")
(description "This package provides a simple test runner that finds and runs
@@ -223,8 +223,7 @@ while being as light-weight and simple as possible.")
(("far.include") "far.exclude(/test-parse.js/)\nfar.include"))
#t)))))
(native-inputs
- `(("node-far" ,node-far)
- ("node-long-stack-traces" ,node-long-stack-traces)))
+ (list node-far node-long-stack-traces))
(home-page "https://github.com/felixge/node-stack-trace")
(synopsis "Get v8 stack traces as an array of CallSite objects")
(description "Get v8 stack traces as an array of CallSite objects.")
@@ -349,7 +348,7 @@ function with browser support.")
;; still works as a dependency of node-glob and node-inflight.
(delete 'configure))))
(inputs
- `(("node-wrappy" ,node-wrappy)))
+ (list node-wrappy))
(home-page "https://github.com/isaacs/once")
(synopsis "Node.js module to call a function only once")
(description
@@ -409,7 +408,7 @@ such as rainbows.")
;; being missing, as we don't have them packaged yet.
(delete 'configure))))
(inputs
- `(("node-irc-colors" ,node-irc-colors)))
+ (list node-irc-colors))
(home-page "https://github.com/martynsmith/node-irc")
(synopsis "IRC client library for Node.js")
(description "@code{node-irc} is an IRC client library for Node.js.