summaryrefslogtreecommitdiff
path: root/gnu/packages/node-xyz.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-01-08 03:42:08 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-01-09 02:07:14 +0100
commit6dec34e25bcd190d6698aa19869b0fb56ceb503a (patch)
tree54f7647b483aa3d3ad67dfa6524d42b4a1cc9aea /gnu/packages/node-xyz.scm
parent5524733bb2653f3a3875812e41ae3566050666c5 (diff)
downloadguix-patches-6dec34e25bcd190d6698aa19869b0fb56ceb503a.tar
guix-patches-6dec34e25bcd190d6698aa19869b0fb56ceb503a.tar.gz
gnu: Add node-string-decoder.
* gnu/packages/node-xyz.scm (node-string-decoder): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/node-xyz.scm')
-rw-r--r--gnu/packages/node-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index f4af03eb87..e8932aeebc 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -420,6 +420,39 @@ defaulting to Node's implementation otherwise.")
@code{Buffer.alloc(SIZE)}) in older versions.")
(license license:expat)))
+(define-public node-string-decoder
+ (package
+ (name "node-string-decoder")
+ (version "1.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/nodejs/string_decoder")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xxvyya9fl9rlkqwmxzqzbz4rdr3jgw4vf37hff7cgscxkhg266k"))))
+ (build-system node-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-dependencies 'delete-dependencies
+ (lambda args
+ (delete-dependencies
+ '("tap" "core-util-is" "babel-polyfill")))))
+ ;; FIXME: Tests depend on node-tap
+ #:tests? #f))
+ (inputs (list node-safe-buffer node-inherits))
+ (home-page "https://github.com/nodejs/string_decoder")
+ (synopsis "Decode buffers while preserving multi-byte sequences ")
+ (description "This package provides a user-land implementation of
+Node-core's @code{string_decoder}, which serves to decode buffers to
+strings so that the decoded string does not contain incomplete multibyte
+sequences.")
+ (license license:expat)))
+
(define-public node-irc-colors
(package
(name "node-irc-colors")