summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2021-05-18 21:38:48 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-28 23:04:44 +0200
commit02f6144344d34ce24a821a6f6ab5e3c9e4bd2e7d (patch)
tree266b42b9832127ec524335d9cf2abd8b9c980dcd /gnu/packages/networking.scm
parent30713c2c2ac8a01931516017dc70f797d6f1a0dd (diff)
downloadguix-patches-02f6144344d34ce24a821a6f6ab5e3c9e4bd2e7d.tar
guix-patches-02f6144344d34ce24a821a6f6ab5e3c9e4bd2e7d.tar.gz
gnu: Add mbuffer.
* gnu/packages/networking.scm (mbuffer): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3da10a2990..f65c8a7f13 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2014, 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015, 2016, 2017, 2018, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016, 2017 Stefan Reichör <stefan@xsteve.at>
+;;; Copyright © 2015, 2016, 2017, 2021 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016–2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
@@ -909,6 +909,38 @@ establish a relatively secure environment (su and chroot) for running client
or server shell scripts with network connections.")
(license license:gpl2)))
+(define-public mbuffer
+ (package
+ (name "mbuffer")
+ (version "20210328")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.maier-komor.de/software/mbuffer/mbuffer-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0pfw9xw4ph18yss07fl6w8fbqiwy1w9r1knzw5gsb4c993cbidai"))))
+ (build-system gnu-build-system)
+ (inputs `(("openssl" ,openssl)))
+ (home-page "http://www.maier-komor.de/mbuffer.html")
+ (synopsis
+ "Swiss army knife for data stream buffering (network aware)")
+ (description
+ "mbuffer is a tool for buffering data streams with a large set of features:
+
+@itemize
+@item direct support for TCP based network targets (IPv4 and IPv6)
+@item ability to send to multiple targets in parallel (distribution mode)
+@item support for multiple volumes
+@item I/O rate limitation
+@item high/low watermark based restart criteria
+@item configurable buffer size
+@item on the fly MD5 hash calculation
+@item highly efficient, multi-threaded implementation
+@end itemize")
+ (license license:gpl3+)))
+
(define-public tcp-wrappers
(package
(name "tcp-wrappers")