summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/networking.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm22
1 files changed, 9 insertions, 13 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 214255ccb5..1ec1586fb3 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -163,12 +163,12 @@
(base32 "10ndzkip8blgkw572n3dicl6mgjaa7kygwn3vls80liq92vf1sa9"))))
(build-system gnu-build-system)
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("libtool" ,libtool)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("which" ,which)))
+ (list autoconf
+ automake
+ libtool
+ pkg-config
+ python-wrapper
+ which))
(home-page "https://github.com/sctplab/usrsctp/")
(synopsis "SCTP user-land implementation")
(description "UsrSCTP is a portable SCTP userland stack. SCTP is a message
@@ -190,8 +190,7 @@ runs on top of IP or UDP, and supports both v4 and v6 versions.")
(base32 "0kmlqk04sgkshsll4r9w3k0rvrgz0gpk987618r50khwl484zss6"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal pkg-config))
(inputs
(list libressl))
(home-page "https://github.com/axel-download-accelerator/axel")
@@ -496,7 +495,7 @@ performance across unpredictable networks, such as the Internet.")
(native-inputs
(list autoconf automake libtool pkg-config))
(inputs
- `(("linux-headers" ,linux-libre-headers)))
+ (list linux-libre-headers))
(synopsis
"@acronym{SCTP, Stream Control Transmission Protocol} helpers for Linux")
(description
@@ -3488,10 +3487,7 @@ A very simple IM client working over the DHT.
(inputs
(list c-ares json-c libcap libyang readline))
(native-inputs
- `(("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)
- ("python-pytest" ,python-pytest)))
+ (list perl pkg-config python-wrapper python-pytest))
(home-page "https://frrouting.org/")
(synopsis "IP routing protocol suite")
(description "FRRouting (FRR) is an IP routing protocol suite which includes