summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-10 14:58:50 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-08-11 00:12:40 -0400
commit34d4bed23c9e46ef2c69ab8c6a4d05de6e533a54 (patch)
treedfe6a93b6c147c59523a56822f20dab0b220ae4f /gnu/packages/networking.scm
parent95b599bd48bb5a8613b13ea295e9b6af86bc4c01 (diff)
downloadguix-patches-34d4bed23c9e46ef2c69ab8c6a4d05de6e533a54.tar
guix-patches-34d4bed23c9e46ef2c69ab8c6a4d05de6e533a54.tar.gz
gnu: Add libsocketcan.
* gnu/packages/networking.scm (libsocketcan): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 25b63779d2..ca0f171b69 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2499,6 +2499,30 @@ networks using zeromq. It has these key characteristics:
(home-page "https://github.com/zeromq/zyre")
(license license:mpl2.0)))
+(define-public libsocketcan
+ (package
+ (name "libsocketcan")
+ (version "0.0.11")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.pengutronix.de/cgit/tools/libsocketcan")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17z2y2r9xkixhr9bxr50m77fh710afl30s7jdhbxrvf56vmal2jr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)))
+ (home-page "https://git.pengutronix.de/cgit/tools/libsocketcan")
+ (synopsis "SocketCAN user-space library")
+ (description "This library allows controlling basic functions in SocketCAN
+from user-space. It requires a kernel built with SocketCAN support.")
+ (license license:lgpl2.1+)))
+
(define-public can-utils
(package
(name "can-utils")