summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-05-02 17:53:40 +0200
commitc3052d6bcd2193b258fb92b99291a4918931fe36 (patch)
tree0e0cbbc019e68f4f1c865b4d2f5e341eb45d96ee /gnu/packages/networking.scm
parent0bfb9b439953b755a510974e51e651f79526a5a4 (diff)
parentb74f64a960542b0679ab13de0dd28adc496cf084 (diff)
downloadguix-patches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar
guix-patches-c3052d6bcd2193b258fb92b99291a4918931fe36.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index a4f431a0b1..306a3a0218 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2015 Stefan Reichör <stefan@xsteve.at>
;;; Copyright © 2016 Raimon Grau <raimonster@gmail.com>
;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
+;;; Copyright 2016 John Darrington <jmd@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -32,6 +33,26 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages compression))
+(define-public macchanger
+ (package
+ (name "macchanger")
+ (version "1.6.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/"
+ name "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xsiivjjyhqcs6dyjcshrnxlgypvyfzacjz7gcjgl88xiw9lylri"))))
+ (build-system gnu-build-system)
+ (home-page "http://www.gnu.org/software/macchanger")
+ (synopsis "Display or change the MAC address of networking devices")
+ (description "GNU MAC Changer is a utility for viewing and changing MAC
+addresses of networking devices. New addresses may be set explicitly or
+randomly. They can include MAC addresses of the same or other hardware vendors
+or, more generally, MAC addresses of the same category of hardware.")
+ (license license:gpl2+)))
+
(define-public miredo
(package
(name "miredo")