summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2021-09-12 22:41:12 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2021-09-12 22:44:06 +0300
commit9d9759f3ae76a53177801446824f5afe39b5ebce (patch)
treee4100478a1676c99935982d44ed35c995372516c /gnu/packages/networking.scm
parent93fba676ba6536f319fcbb157a018960930e80aa (diff)
downloadguix-patches-9d9759f3ae76a53177801446824f5afe39b5ebce.tar
guix-patches-9d9759f3ae76a53177801446824f5afe39b5ebce.tar.gz
gnu: Add bird.
* gnu/packages/networking.scm (bird): New variable.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 7f0b7f53cc..3657d69511 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2018, 2020, 2021 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2018, 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2020, 2021 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019, 2020, 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Vasile Dumitrascu <va511e@yahoo.com>
@@ -3536,6 +3536,39 @@ A very simple IM client working over the DHT.
protocol daemons for BGP, IS-IS, LDP, OSPF, PIM, and RIP. ")
(license license:gpl2+)))
+(define-public bird
+ (package
+ (name "bird")
+ (version "2.0.8")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "ftp://bird.network.cz/pub/bird/bird-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1xp7f0im1v8pqqx3xqyfkd1nsxk8vnbqgrdrwnwhg8r5xs1xxlhr"))))
+ (inputs
+ `(("libssh" ,libssh)
+ ("readline" ,readline)))
+ (native-inputs
+ `(("bison" ,bison)
+ ("flex" ,flex)))
+ (arguments
+ `(#:configure-flags '("--localstatedir=/var" "--enable-ipv6")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'dont-create-sysconfdir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile.in"
+ ((" \\$\\(DESTDIR)/\\$\\(runstatedir)") "")))))))
+ (build-system gnu-build-system)
+ (home-page "http://bird.network.cz")
+ (synopsis "Internet Routing Daemon")
+ (description "BIRD is an Internet routing daemon with full support for all
+the major routing protocols. It allows redistribution between protocols with a
+powerful route filtering syntax and an easy-to-use configuration interface.")
+ (license license:gpl2+)))
+
(define-public iwd
(package
(name "iwd")