summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-12-20 16:56:39 +0100
committerMarius Bakke <marius@gnu.org>2020-12-20 19:00:41 +0100
commitd0abf4523f639830d1eb9506fe3d1205ce881fc3 (patch)
treeb7101e3923568bb34b0271268e1c44ba7ff2cd3b /gnu/packages/networking.scm
parent6203b8e5bdb9e76a4d83d3679d766d024ad234aa (diff)
downloadguix-patches-d0abf4523f639830d1eb9506fe3d1205ce881fc3.tar
guix-patches-d0abf4523f639830d1eb9506fe3d1205ce881fc3.tar.gz
gnu: rtmpdump: Update to 2.4-0.c5f04a5 [security fixes].
* gnu/packages/networking.scm (rtmpdump): Update to 2.4-0.c5f04a5. [arguments]: Add phase prefer-gnutls. [inputs]: Remove OPENSSL-1.0. Add GNUTLS.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm101
1 files changed, 57 insertions, 44 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 2d5e9b55f9..dcf04968f5 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -294,51 +294,64 @@ GLib-based library, libnice, as well as GStreamer elements to use it.")
license:mpl1.1))))
(define-public rtmpdump
- (package
- (name "rtmpdump")
- (version "2.4")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.ffmpeg.org/rtmpdump")
- (commit "c28f1bab7822de97353849e7787b59e50bbb1428")))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1n3kdip83nvvs4sin30zpcdr5q711mqhq2lxrv5vgbc6lskpwzlj"))))
- (build-system gnu-build-system)
- (arguments
- `(#:tests? #f ; no tests
- #:make-flags
- (list
- ;; The ‘validate-runpath’ phase fails to find librtmp.so.0.
- (string-append "LDFLAGS=-Wl,-rpath="
- (assoc-ref %outputs "out") "/lib")
- (string-append "prefix=" (assoc-ref %outputs "out")))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'omit-static-library
- (lambda _
- (substitute* "librtmp/Makefile"
- (("cp librtmp\\.a .*") ; don't install it
- "")
- (("librtmp\\.a ") ; don't build it
- ""))
- #t))
- (delete 'configure))))
- (inputs
- `(("openssl" ,openssl-1.0)
- ("zlib" ,zlib)))
- (synopsis "Tools and library for handling RTMP streams")
- (description "RTMPdump is a toolkit for RTMP streams. All forms of RTMP are
+ ;; There are no tags in the repository, and the project is unlikely to
+ ;; make new releases. Take a recent commit for multiple security fixes
+ ;; as well as GnuTLS compatibility.
+ (let ((commit "c5f04a58fc2aeea6296ca7c44ee4734c18401aa3")
+ (revision "0")
+ (version "2.4")) ;as mentioned in README and man pages
+ (package
+ (name "rtmpdump")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.ffmpeg.org/rtmpdump")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07ias612jgmxpam9h418kvlag32da914jsnjsfyafklpnh8gdzjb"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list
+ ;; The ‘validate-runpath’ phase fails to find librtmp.so.0.
+ (string-append "LDFLAGS=-Wl,-rpath="
+ (assoc-ref %outputs "out") "/lib")
+ (string-append "prefix=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'omit-static-library
+ (lambda _
+ (substitute* "librtmp/Makefile"
+ (("cp librtmp\\.a .*") ; don't install it
+ "")
+ (("librtmp\\.a ") ; don't build it
+ ""))
+ #t))
+ (add-after 'unpack 'prefer-gnutls
+ (lambda _
+ (substitute* '("Makefile" "librtmp/Makefile")
+ (("CRYPTO=OPENSSL")
+ "#CRYPTO=OPENSSL")
+ (("#CRYPTO=GNUTLS")
+ "CRYPTO=GNUTLS"))))
+ (delete 'configure))))
+ (inputs
+ `(("gnutls" ,gnutls)
+ ("zlib" ,zlib)))
+ (synopsis "Tools and library for handling RTMP streams")
+ (description "RTMPdump is a toolkit for RTMP streams. All forms of RTMP are
supported, including rtmp://, rtmpt://, rtmpe://, rtmpte://, and rtmps://.")
- (home-page "https://rtmpdump.mplayerhq.hu/")
- (license
- (list
- ;; Library.
- license:lgpl2.1+
- ;; Others.
- license:gpl2+))))
+ (home-page "https://rtmpdump.mplayerhq.hu/")
+ (license
+ (list
+ ;; Library.
+ license:lgpl2.1+
+ ;; Others.
+ license:gpl2+)))))
(define-public srt
(package