summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 01:30:38 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-11-03 03:10:53 +0100
commitc1f2c6c39ee04575fbed22d8a145c89fdeea81da (patch)
tree510d52fc671864b6ed21797dc5055f59c71d62e0 /gnu/packages/networking.scm
parenta807ae26668367f66bfe6a5ae541e14ed94651a5 (diff)
downloadguix-patches-c1f2c6c39ee04575fbed22d8a145c89fdeea81da.tar
guix-patches-c1f2c6c39ee04575fbed22d8a145c89fdeea81da.tar.gz
gnu: putty: Try the upstream download URL first.
* gnu/packages/networking.scm (putty)[source]: Add greenend.org.uk URL to the list.
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index cdd8decc78..aa484c505e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4213,8 +4213,10 @@ on hub/switched networks. It is based on @acronym{ARP} packets, it will send
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.putty.be/" version
- "/putty-" version ".tar.gz"))
+ (uri (list (string-append "https://the.earth.li/~sgtatham/putty/"
+ version "/putty-" version ".tar.gz")
+ (string-append "http://www.putty.be/" version
+ "/putty-" version ".tar.gz")))
(sha256
(base32 "0gvi8phabszqksj2by5jrjmshm7bpirhgavz0dqyz1xaimxdjz2l"))))
(build-system gnu-build-system)