summaryrefslogtreecommitdiff
path: root/gnu/packages/networking.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <raghavgururajan@disroot.org>2020-07-03 09:44:14 -0400
committerDanny Milosavljevic <dannym@scratchpost.org>2020-08-18 22:56:35 +0200
commit63d18ff6b918b062521b88efbf9964bdbe8eb276 (patch)
tree6d7b42971e2e1fc5ca7c038e621dff409b70a66c /gnu/packages/networking.scm
parent24a2aaf3ff04232fe9c23bb0a9da2a93324a0ab3 (diff)
downloadguix-patches-63d18ff6b918b062521b88efbf9964bdbe8eb276.tar
guix-patches-63d18ff6b918b062521b88efbf9964bdbe8eb276.tar.gz
gnu: Add srt.
* gnu/packages/networking.scm (srt): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/networking.scm')
-rw-r--r--gnu/packages/networking.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 13974ead4a..5158d9c1c7 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -125,14 +125,57 @@
#:use-module (gnu packages shells)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages tcl)
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages version-control)
#:use-module (gnu packages web)
#:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
+(define-public srt
+ (package
+ (name "srt")
+ (version "1.4.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/Haivision/srt.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01xaq44j95kbgqfl41pnybvqy0yq6wd4wdw88ckylzf0nzp977xz"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ (list
+ (string-append "-DCMAKE_INSTALL_BINDIR="
+ (assoc-ref %outputs "out") "/bin")
+ (string-append "-DCMAKE_INSTALL_LIBDIR="
+ (assoc-ref %outputs "out") "/lib")
+ (string-append "-DINSTALL_SHARED_DIR="
+ (assoc-ref %outputs "out") "/lib")
+ (string-append "-DCMAKE_INSTALL_INCLUDEDIR="
+ (assoc-ref %outputs "out") "/include")
+ "-DENABLE_UNITTESTS=ON"
+ "-DENABLE_CODE_COVERAGE=ON")))
+ (native-inputs
+ `(("git" ,git-minimal)
+ ("gtest" ,googletest)
+ ("pkg-config" ,pkg-config)
+ ("tclsh" ,tcl)))
+ (propagated-inputs
+ `(("openssl" ,openssl)))
+ (synopsis "Secure Reliable Transport")
+ (description "SRT is a transport technology that optimizes streaming
+performance across unpredictable networks, such as the Internet.")
+ (home-page "https://www.srtalliance.org/")
+ (license license:mpl2.0)))
+
(define-public lksctp-tools
(package
(name "lksctp-tools")