summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 13:39:30 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:15 -0400
commita5a84babb985f3a3d242e3fb0e225dcc826875d5 (patch)
tree377be7354c7255ad4dae0f596914953e672c5c1d /gnu/packages/music.scm
parentcfce386aba9a052e4dfdb255e809f6b10f4f8242 (diff)
downloadguix-patches-a5a84babb985f3a3d242e3fb0e225dcc826875d5.tar
guix-patches-a5a84babb985f3a3d242e3fb0e225dcc826875d5.tar.gz
gnu: Remove ingen.
* gnu/packages/music.scm (ingen): Delete variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm85
1 files changed, 0 insertions, 85 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 6a26b30a91..8183ac942e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -4482,91 +4482,6 @@ filters, crossovers, simple gain plugins without zipper noise, switch box
plugins, a switch trigger, a toggle switch, and a peakmeter.")
(license license:gpl2+))))
-(define-public ingen
- (let ((commit "cc4a4db33f4d126a07a4a498e053c5fb9a883be3")
- (revision "2"))
- (package
- (name "ingen")
- (version (string-append "0.0.0-" revision "."
- (string-take commit 9)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.drobilla.net/ingen.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "1wg47vjw9djn99gbnsl2bcwj4xhdid61m4wrbn2nlp797flj91ic"))))
- (build-system waf-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f ; no "check" target
- #:configure-flags (list "--no-webkit")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-wscript
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (substitute* "wscript"
- ;; FIXME: Our version of lv2specgen.py does not behave as
- ;; expected. Maybe this requires a development version of
- ;; LV2.
- (("lv2specgen.py") "touch ingen.lv2/ingen.html; echo")
- ;; Add libraries to RUNPATH.
- (("^(.+)target.*= 'src/ingen/ingen'," line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line)))
- (substitute* '("src/wscript"
- "src/server/wscript")
- ;; Add libraries to RUNPATH.
- (("bld.env.PTHREAD_LINKFLAGS" line)
- (string-append line
- " + [\"-Wl,-rpath=" out "/lib" "\"]")))
- (substitute* "src/client/wscript"
- ;; Add libraries to RUNPATH.
- (("^(.+)target.*= 'ingen_client'," line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line)))
- (substitute* "src/gui/wscript"
- ;; Add libraries to RUNPATH.
- (("^(.+)target.* = 'ingen_gui.*" line prefix)
- (string-append prefix
- "linkflags=[\"-Wl,-rpath="
- out "/lib" "\"]," line))))
- #t)))))
- (inputs
- (list boost
- python-rdflib
- python
- jack-1
- lv2
- lilv
- raul-devel
- ganv
- suil
- serd
- sord
- sratom
- gtkmm-2))
- (native-inputs
- (list pkg-config python-pygments))
- (home-page "https://drobilla.net/software/ingen")
- (synopsis "Modular audio processing system")
- (description "Ingen is a modular audio processing system for JACK and
-LV2 based systems. Ingen is built around LV2 technology and a strict
-separation of engine from user interface. The engine is controlled
-exclusively through a protocol, and can execute as a headless process, with an
-in-process GUI, or as an LV2 plugin. The GUI can run as a program which
-communicates over a Unix or TCP/IP socket, or as an embeddable LV2 GUI which
-communicates via LV2 ports. Any saved Ingen graph can be loaded as an LV2
-plugin on any system where Ingen is installed. This allows users to visually
-develop custom plugins for use in other applications without programming.")
- (license license:agpl3+))))
-
(define-public qmidiarp
(package
(name "qmidiarp")