summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-04-29 17:35:54 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:52:32 -0400
commita240fef7076677858ff41d3abf4c8d7830108427 (patch)
tree7a8792576a7c0229b21e1c768ad75e5d105bff96 /gnu/packages/music.scm
parentded6dbcb49e50ff8d26e091d8d3081bf07539809 (diff)
downloadguix-patches-a240fef7076677858ff41d3abf4c8d7830108427.tar
guix-patches-a240fef7076677858ff41d3abf4c8d7830108427.tar.gz
gnu: Remove mloop.
* gnu/packages/music.scm (mloop): Delete variable.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm39
1 files changed, 0 insertions, 39 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index ff5dc1aeb1..1d07993416 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5555,45 +5555,6 @@ with error and volume history, and advanced features.")
;; are under LGPL2.1.
(license (list license:gpl2+ license:lgpl2.1))))
-(define-public mloop
- (let ((commit "adebff98b0b4dc5872a03acb82e89c77cb29c127")
- (revision "0"))
- (package
- (name "mloop")
- (version (git-version "0.0.1" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "http://git.fuzzle.org/mloop")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "175gxvg5slq0bllcx1c381rjlq3xpxww8c3kpiw5i2kfr4m52myz"))))
- (build-system waf-build-system)
- (arguments
- `(#:python ,python-2
- #:tests? #f)) ; no "check" target
- (inputs
- (list jack-1 ncurses))
- (native-inputs
- (list pkg-config))
- (home-page "https://fuzzle.org/~petern/mloop.html")
- (synopsis "Live MIDI looper")
- (description "mloop is a live MIDI looping system, using jack-midi.
-Loops are recorded, optionally with beat quantization, and can then be played
-back, either once or looping. A 'note cache' system is implemented to
-remember which notes are pressed and their velocities. This allows for a loop
-to start off with the currently pressed notes, making seamless loops much
-easier to perform. Features include:
-
-@itemize
-@item Quantisation; end a loop on a beat exactly.
-@item Delayed recording; wait for a MIDI event before starting a loop record.
-@item Adjust tempo; Playback speed of loops can be adjusted on the fly.
-@end itemize\n")
- (license license:gpl2))))
-
(define-public pragha
(package
(name "pragha")