summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-11-27 01:13:53 -0500
committerLeo Famulari <leo@famulari.name>2016-11-27 14:49:36 -0500
commitd3db5efbf97dd0d880b18c8fc0d3c76d91fd6e4d (patch)
tree181e3786f4799e5ad473b13f8fc21eebb8eff715 /gnu/packages/music.scm
parent6782444764d6072ef2684403efb92ca1aaabc016 (diff)
downloadguix-patches-d3db5efbf97dd0d880b18c8fc0d3c76d91fd6e4d.tar
guix-patches-d3db5efbf97dd0d880b18c8fc0d3c76d91fd6e4d.tar.gz
gnu: Add python-discogs-client.
* gnu/packages/music.scm (python-discogs-client, python2-discogs-client): New variables.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c2a995d02f..b8145bbbb6 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2427,3 +2427,37 @@ a simulation of an analog Wah pedal with switchless activation."))))
filters, crossovers, simple gain plugins without zipper noise, switch box
plugins, a switch trigger, a toggle switch, and a peakmeter.")
(license license:gpl2+))))
+
+(define-public python-discogs-client
+ (package
+ (name "python-discogs-client")
+ (version "2.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "discogs-client" version))
+ (sha256
+ (base32
+ "053ld2psh0yj3z0kg6z5bn4y3cr562m727494n0ayhgzbkjbacly"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-oauthlib" ,python-oauthlib)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-six" ,python-six)))
+ (home-page "https://github.com/discogs/discogs_client")
+ (synopsis "Official Python client for the Discogs API")
+ (description "This is the official Discogs API client for Python. It enables
+you to query the Discogs database for information on artists, releases, labels,
+users, Marketplace listings, and more. It also supports OAuth 1.0a
+authorization, which allows you to change user data such as profile information,
+collections and wantlists, inventory, and orders.")
+ (license license:bsd-2)
+ (properties `((python2-variant . ,(delay python2-discogs-client))))))
+
+(define-public python2-discogs-client
+ (let ((base (package-with-python2
+ (strip-python2-variant python-discogs-client))))
+ (package (inherit base)
+ (native-inputs
+ `(("python2-setuptools" ,python2-setuptools)
+ ,@(package-native-inputs base))))))