summaryrefslogtreecommitdiff
path: root/gnu/packages/music.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-12-04 20:51:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-12-06 10:15:49 +0100
commit5a66e25ce631802b4a3fcc16fca20ae67e77c34e (patch)
tree2fbf2f44fa4d9d77ba83afcc60f4a356bf41ea28 /gnu/packages/music.scm
parent24420005ec730e6abe05a9cfc34e0fd87ee24c9c (diff)
downloadguix-patches-5a66e25ce631802b4a3fcc16fca20ae67e77c34e.tar
guix-patches-5a66e25ce631802b4a3fcc16fca20ae67e77c34e.tar.gz
gnu: Add seq24.
* gnu/packages/music.scm (seq24): New variable. * gnu/packages/patches/seq24-rename-mutex.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch.
Diffstat (limited to 'gnu/packages/music.scm')
-rw-r--r--gnu/packages/music.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index b3e66fff94..e1ab90b001 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -2598,6 +2598,36 @@ sequencer and LFO. It can hold any number of arpeggiator, sequencer, or LFO
modules running in parallel.")
(license license:gpl2+)))
+(define-public seq24
+ (package
+ (name "seq24")
+ (version "0.9.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://launchpad.net/seq24/trunk/"
+ version "/+download/seq24-"
+ version ".tar.bz2"))
+ (sha256
+ (base32
+ "12dphdhnvfk1k0vmagi1v2lhyxjyj1j3cz6ksjw0ydcvid1x8ap2"))
+ (patches (search-patches "seq24-rename-mutex.patch"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "CXXFLAGS=-std=gnu++11")))
+ (inputs
+ `(("gtkmm" ,gtkmm-2)
+ ("alsa-lib" ,alsa-lib)
+ ("jack" ,jack-1)
+ ("lash" ,lash)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://edge.launchpad.net/seq24/")
+ (synopsis "Real-time MIDI sequencer")
+ (description "Seq24 is a real-time MIDI sequencer. It was created to
+provide a very simple interface for editing and playing MIDI loops.")
+ (license license:gpl2+)))
+
(define-public python-discogs-client
(package
(name "python-discogs-client")