summaryrefslogtreecommitdiff
path: root/gnu/packages/mpd.scm
diff options
context:
space:
mode:
authorSimon Streit <simon@netpanic.org>2023-01-20 20:07:09 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-02-23 15:25:43 +0100
commita694ef48023b83bd2938a62c1830aee6cc2513b4 (patch)
treecb4385e7014dd926d02c254e7952549e7270615c /gnu/packages/mpd.scm
parent415db66877a95987755b96779672172fff51ac99 (diff)
downloadguix-patches-a694ef48023b83bd2938a62c1830aee6cc2513b4.tar
guix-patches-a694ef48023b83bd2938a62c1830aee6cc2513b4.tar.gz
gnu: mpdris2: Remove input labels and add inputs.
* gnu/packages/mpd.scm (mpdris2)[arguments]: Use G-expressions. Remove trailing #T from phase. [inputs]: Remove labels. Add BASH-MINIMAL and PYTHON-MUTAGEN. [native-inputs]: Remove labels. [description]: Use complete sentence.
Diffstat (limited to 'gnu/packages/mpd.scm')
-rw-r--r--gnu/packages/mpd.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index 74f43ecbb3..5288aeda3e 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
;;; Copyright © 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
-;;; Copyright © 2020–2022 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2020–2023 Simon Streit <simon@netpanic.org>
;;; Copyright © 2021 Noah Evans <noah@nevans.me>
;;;
;;; This file is part of GNU Guix.
@@ -444,27 +444,30 @@ other MPD frontends.")
(build-system gnu-build-system)
;; Manually wrap the binary, because we’re not using python-build-system.
(arguments
- '(#:phases
- (modify-phases %standard-phases
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (python-path (getenv "GUIX_PYTHONPATH")))
- (wrap-program (string-append out "/bin/mpDris2")
- `("GUIX_PYTHONPATH" ":" prefix (,python-path)))
- #t))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-program
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((python-path (getenv "GUIX_PYTHONPATH")))
+ (wrap-program (string-append #$output "/bin/mpDris2")
+ `("GUIX_PYTHONPATH" ":" prefix (,python-path)))))))))
(inputs
- (list python-mpd2 python-dbus python-pygobject python)) ; Sets GUIX_PYTHONPATH.
- ;; For bootstrapping.
+ (list bash-minimal
+ python
+ python-dbus
+ python-mpd2
+ python-mutagen
+ python-pygobject))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)
- ("gettext" ,gettext-minimal)
- ("which" ,which)
- ("intltool" ,intltool)))
+ (list autoconf
+ automake
+ gettext-minimal
+ intltool
+ which))
(synopsis "MPRIS V2.1 support for MPD")
- (description "Client for the Music Player Daemon providing MPRIS 2
-support")
+ (description "mpDris2 is a client for the Music Player Daemon providing
+MPRIS 2 support.")
(home-page "https://github.com/eonpatapon/mpDris2")
(license license:gpl3+)))