summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-09-18 15:31:18 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-09-18 15:31:18 +0200
commit19c9c266ae1de85e9d731e3ad829c8273b641c83 (patch)
tree5c00f9588ba3a75eaf65faada10b78b7cc2c1a5d /gnu/packages/mp3.scm
parent642fcb1d08548fa887b4561f2590df62cd8eacbc (diff)
downloadguix-patches-19c9c266ae1de85e9d731e3ad829c8273b641c83.tar
guix-patches-19c9c266ae1de85e9d731e3ad829c8273b641c83.tar.gz
gnu: mpg321: Fix compiling with gcc 10.
* gnu/packages/patches/mpg321-gcc-10.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/mp3.scm (mpg321)[source]: Use it.
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 43398f1e46..406d010193 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -412,7 +413,8 @@ command-line tool as well as a C library, libmpg123.")
(base32
"0ki8mh76bbmdh77qsiw682dvi8y468yhbdabqwg05igmwc1wqvq5"))
(patches
- (search-patches "mpg321-CVE-2019-14247.patch"))))
+ (search-patches "mpg321-CVE-2019-14247.patch"
+ "mpg321-gcc-10.patch"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-alsa")))
(inputs