summaryrefslogtreecommitdiff
path: root/gnu/packages/mp3.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2021-02-03 09:14:43 +0000
committerChristopher Baines <mail@cbaines.net>2021-02-03 09:57:35 +0000
commite740cc614096e768813280c718f9e96343ba41b3 (patch)
tree25ade70a5d408be80f62f19c6511172aab7dcce5 /gnu/packages/mp3.scm
parent1b9186828867e77af1f2ee6741063424f8256398 (diff)
parent63cf277bfacf282d2b19f00553745b2a9370eca0 (diff)
downloadguix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar
guix-patches-e740cc614096e768813280c718f9e96343ba41b3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/mp3.scm')
-rw-r--r--gnu/packages/mp3.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index c32b3cba11..34390d3696 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -82,6 +82,10 @@
;; remove option that is not supported by gcc any more
(substitute* "configure" ((" -fforce-mem") ""))
#t))
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -127,6 +131,10 @@ This package contains the library.")
(arguments
`(#:phases
(modify-phases %standard-phases
+ ;; Normally one should not add a pkg-config file if one is not provided
+ ;; by upstream developers, but Audacity expects a pkg-config file for
+ ;; this package, and other major GNU/Linux distributions already provide
+ ;; such a file.
(add-after 'install 'install-pkg-config
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))