summaryrefslogtreecommitdiff
path: root/gnu/packages/mono.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
commitb03e4fd5269897448124a7b61a737802b2c638ee (patch)
treee4eaab1d3076e335c57eea462ff7fda7919f0831 /gnu/packages/mono.scm
parentda3c6a7f19ef1243af725f63c16c8fd92fde33b4 (diff)
parent99aad42138e0895df51e64e1261984f277952516 (diff)
downloadguix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar
guix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/mono.scm')
-rw-r--r--gnu/packages/mono.scm23
1 files changed, 20 insertions, 3 deletions
diff --git a/gnu/packages/mono.scm b/gnu/packages/mono.scm
index 343cebc99f..17f90fe30a 100644
--- a/gnu/packages/mono.scm
+++ b/gnu/packages/mono.scm
@@ -41,7 +41,8 @@
".tar.bz2"))
(sha256
(base32
- "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))))
+ "0jibyvyv2jy8dq5ij0j00iq3v74r0y90dcjc3dkspcfbnn37cphn"))
+ (patches (search-patches "mono-mdoc-timestamping.patch"))))
(build-system gnu-build-system)
(native-inputs
`(("gettext" ,gettext-minimal)
@@ -52,10 +53,26 @@
(arguments
`(#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'make-reproducible
+ (lambda _
+ (substitute* "mono/mini/Makefile.in"
+ (("build_date = [^;]*;")
+ "build_date = (void*) 0;"))
+ #t))
(add-after 'unpack 'set-env
(lambda _ ;;* (#:key inputs #:allow-other-keys)
;; all tests under mcs/class fail trying to access $HOME
- (setenv "HOME" "/tmp")))
+ (setenv "HOME" "/tmp")
+ ;; ZIP files have "DOS time" which starts in Jan 1980.
+ (setenv "SOURCE_DATE_EPOCH" "315532800")
+ #t))
+ (add-after 'unpack 'fix-includes
+ (lambda _
+ ;; makedev is in <sys/sysmacros.h> now. Include it.
+ (substitute* "mono/io-layer/processes.c"
+ (("#ifdef HAVE_SYS_MKDEV_H") "#if 1")
+ (("sys/mkdev.h") "sys/sysmacros.h"))
+ #t))
(add-after 'unpack 'patch-tests
(lambda _ ;;* (#:key inputs #:allow-other-keys)
(substitute* "mono/tests/Makefile.in"
@@ -105,5 +122,5 @@
(description "Mono is a compiler, vm, debugger and set of libraries for
C#, a C-style programming language from Microsoft that is very similar to
Java.")
- (home-page "http://mono-project.com/")
+ (home-page "https://www.mono-project.com/")
(license license:x11)))