summaryrefslogtreecommitdiff
path: root/gnu/packages/monitoring.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/monitoring.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/monitoring.scm')
-rw-r--r--gnu/packages/monitoring.scm24
1 files changed, 9 insertions, 15 deletions
diff --git a/gnu/packages/monitoring.scm b/gnu/packages/monitoring.scm
index 46dea5eeb8..999cfcb8b0 100644
--- a/gnu/packages/monitoring.scm
+++ b/gnu/packages/monitoring.scm
@@ -377,32 +377,29 @@ recent data to degrade into lower resolutions for long-term retention of
historical data.")
(license license:asl2.0)))
-(define-public python2-whisper
- (package-with-python2 python-whisper))
-
-(define-public python2-carbon
+(define-public python-carbon
(package
- (name "python2-carbon")
- (version "1.0.2")
+ (name "python-carbon")
+ (version "1.1.8")
(source
(origin
(method url-fetch)
(uri (pypi-uri "carbon" version))
(sha256
(base32
- "142smpmgbnjinvfb6s4ijazish4vfgzyd8zcmdkh55y051fkixkn"))))
+ "1wb91fipk1niciffq5xwqbh8g7rl7ghdam4m97cjbig12i5qr4cm"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2 ; only supports Python 2
- #:phases
+ `(#:phases
(modify-phases %standard-phases
;; Don't install to /opt
(add-after 'unpack 'do-not-install-to-/opt
(lambda _ (setenv "GRAPHITE_NO_PREFIX" "1") #t)))))
(propagated-inputs
- `(("python2-whisper" ,python2-whisper)
- ("python2-configparser" ,python2-configparser)
- ("python2-txamqp" ,python2-txamqp)))
+ `(("python-cachetools" ,python-cachetools)
+ ("python-txamqp" ,python-txamqp)
+ ("python-urllib3" ,python-urllib3)
+ ("python-whisper" ,python-whisper)))
(home-page "http://graphiteapp.org/")
(synopsis "Backend data caching and persistence daemon for Graphite")
(description "Carbon is a backend data caching and persistence daemon for
@@ -485,9 +482,6 @@ Metrics can be exposed through a standalone web server, or through Twisted,
WSGI and the node exporter textfile collector.")
(license license:asl2.0)))
-(define-public python2-prometheus-client
- (package-with-python2 python-prometheus-client))
-
(define-public go-github-com-prometheus-node-exporter
(package
(name "go-github-com-prometheus-node-exporter")