summaryrefslogtreecommitdiff
path: root/gnu/packages/minetest.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-10 17:07:17 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-20 12:41:53 +0200
commit7b9d5b6ca023647158bdc0be18ff0f6412097c41 (patch)
treeb39cf8c3bbd1e2e852afe50186628e7b0f7e82e9 /gnu/packages/minetest.scm
parentbb61100ee320b749f644f6847dba5bcb92d3c5aa (diff)
downloadguix-patches-7b9d5b6ca023647158bdc0be18ff0f6412097c41.tar
guix-patches-7b9d5b6ca023647158bdc0be18ff0f6412097c41.tar.gz
gnu: minetest: New package module.
Aside from the 'minetest-topic' procedure which will be used for the 'home-page' field of some packages, this module is currently empty. The 'contentdb' importer defined in the following patches will be used to populate this module. * gnu/packages/minetest.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/minetest.scm')
-rw-r--r--gnu/packages/minetest.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
new file mode 100644
index 0000000000..f8aca3005c
--- /dev/null
+++ b/gnu/packages/minetest.scm
@@ -0,0 +1,26 @@
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+(define-module (gnu packages minetest)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system minetest)
+ #:use-module ((guix licenses) #:prefix license:))
+
+(define-public (minetest-topic topic-id)
+ "Return an URL (as a string) pointing to the forum topic with
+numeric identifier TOPIC-ID on the official Minetest forums."
+ (string-append "https://forum.minetest.net/viewtopic.php?t="
+ (number->string topic-id)))