summaryrefslogtreecommitdiff
path: root/gnu/packages/minetest.scm
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-08-10 17:07:34 +0200
committerLeo Prikler <leo.prikler@student.tugraz.at>2021-08-20 12:41:56 +0200
commit10fc3e37c6f0e6cd4d6a5a71da81e444f12c6b79 (patch)
tree44c9de62004e83115e1d1a1e3214ce973934f4f4 /gnu/packages/minetest.scm
parent948677b67ea46500cb49e388668a80d74304417e (diff)
downloadguix-patches-10fc3e37c6f0e6cd4d6a5a71da81e444f12c6b79.tar
guix-patches-10fc3e37c6f0e6cd4d6a5a71da81e444f12c6b79.tar.gz
gnu: Add minetest-homedecor-modpack.
* gnu/packages/minetest.scm (minetest-homedecor-modpack): New variable. Signed-off-by: Leo Prikler <leo.prikler@student.tugraz.at>
Diffstat (limited to 'gnu/packages/minetest.scm')
-rw-r--r--gnu/packages/minetest.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/minetest.scm b/gnu/packages/minetest.scm
index 3cd14a6df8..3bd640da45 100644
--- a/gnu/packages/minetest.scm
+++ b/gnu/packages/minetest.scm
@@ -107,6 +107,37 @@ special items, intending to make an interesting adventure.")
(license (list license:cc0 license:expat))
(properties `((upstream-name . "TenPlus1/ethereal"))))))
+(define-public minetest-homedecor-modpack
+ (package
+ (name "minetest-homedecor-modpack")
+ ;; Upstream doesn't tag releases, so use the release title from
+ ;; ContentDB as version.
+ (version "2021-03-27-1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/VanessaE/homedecor_modpack")
+ (commit "9ffe2b7d691133e1a067546574fbe7364fd02f32")))
+ (sha256
+ (base32 "1lfajqvc2adf9hqskghky4arccqzpjw4i9a01hv4qcckvivm04ag"))
+ (file-name (git-file-name name version))))
+ (build-system minetest-mod-build-system)
+ (propagated-inputs
+ `(("minetest-basic-materials" ,minetest-basic-materials)
+ ("minetest-unifieddyes" ,minetest-unifieddyes)))
+ (home-page (minetest-topic 2041))
+ (synopsis "Home decor mod for Minetest")
+ (description
+ ;; TRANSLATORS: ‘homedecor’ is the name is the name of a Minetest mod
+ ;; and should not be translated.
+ "The homedecor Minetest mod provides a large seleection of items that
+might be found inside and around homes, such as sofas, chairs, tables, fences
+and a variety of other stuff.")
+ (license
+ (list license:cc-by-sa4.0 license:lgpl3))
+ (properties `((upstream-name . "VanessaE/homedecor_modpack")))))
+
(define-public minetest-mesecons
;; The release on ContentDB does not have its own version number.
(let ((commit "db5879706d04d3480bc4863ce0c03fa73e5f10c7")