summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2017-03-07 07:51:51 +0100
committerJohn Darrington <jmd@gnu.org>2017-03-18 10:31:50 +0100
commita53d6719bc6b6b4afdc58e257ac712df316c8858 (patch)
tree7d1f4b4c5c7e0650523e191995487898f36cce7c /gnu/packages/maths.scm
parentb6bd9a79d48afcdef65c43f4f3af6564455d1af8 (diff)
downloadguix-patches-a53d6719bc6b6b4afdc58e257ac712df316c8858.tar
guix-patches-a53d6719bc6b6b4afdc58e257ac712df316c8858.tar.gz
gnu: Add itpp.
* gnu/packages/maths.scm (itpp): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index adc81561c7..fe85983c24 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2014, 2016 John Darrington <jmd@gnu.org>
+;;; Copyright © 2014, 2016, 2017 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
@@ -761,6 +761,34 @@ Swath).")
HDF5 file is encoded according to the HDF File Format Specification.")
(license (license:x11-style "file://COPYING"))))
+(define-public itpp
+ (package
+ (name "itpp")
+ (version "4.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/itpp/itpp/"
+ version "/itpp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14ddy2xnb6sgp4hiax9v5sv4pr4l4dd4ps76nfha3nrpr1ikhcqm"))))
+ (build-system cmake-build-system)
+ (arguments `(#:tests? #f)) ; Tests require googletest *sources*
+ (inputs `(("lapack" ,lapack)
+ ("fftw" ,fftw)))
+ (native-inputs `(("texlive-minimal" ,texlive-minimal)
+ ("doxygen" ,doxygen)))
+ (home-page "http://itpp.sourceforge.net")
+ (synopsis "C++ library of maths, signal processing and communication classes")
+ (description "IT++ is a C++ library of mathematical, signal processing and
+communication classes and functions. Its main use is in simulation of
+communication systems and for performing research in the area of
+communications. The kernel of the library consists of generic vector and
+matrix classes, and a set of accompanying routines. Such a kernel makes IT++
+similar to MATLAB, GNU Octave or SciPy.")
+ (license license:gpl3+)))
+
(define-public netcdf
(package
(name "netcdf")