summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-16 08:52:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-16 09:33:11 +0300
commit953a12fa9b024e5745ad1ec530217a0ba55b9d78 (patch)
tree6d792efb60cb5ea2f02118439161993573d73b95 /gnu/packages/maths.scm
parent8343d373d5038d230652a51190f6a7c986674df6 (diff)
downloadguix-patches-953a12fa9b024e5745ad1ec530217a0ba55b9d78.tar
guix-patches-953a12fa9b024e5745ad1ec530217a0ba55b9d78.tar.gz
gnu: hdf4: Fix building on aarch64.
* gnu/packages/maths.scm (hdf4)[arguments]: Add a phase to improve detection and support for aarch64-linux.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1bb9f10ecd..3f1dc845fe 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -585,6 +585,14 @@ computations.")
#:configure-flags '("--enable-shared")
#:phases
(modify-phases %standard-phases
+ ;; This is inspired by two of Debian's patches.
+ (add-before 'configure 'add-more-aarch64-support
+ (lambda _
+ (substitute* '("mfhdf/ncgen/ncgen.l"
+ "mfhdf/ncgen/ncgenyy.c"
+ "mfhdf/libsrc/netcdf.h.in")
+ (("AIX5L64") "__aarch64__"))
+ #t))
(add-before 'configure 'patchbuild
(lambda _
(substitute*
@@ -596,7 +604,8 @@ computations.")
-R\\$\\(abs_top_builddir\\)/mfhdf/xdr/\\.libs") "")
(("@HDF_BUILD_SHARED_TRUE@AM_LDFLAGS = \
-R\\$\\(abs_top_builddir\\)/mfhdf/libsrc/\\.libs \
--R\\$\\(abs_top_builddir\\)/hdf/src/\\.libs \\$\\(XDR_ADD\\)") "")))))))
+-R\\$\\(abs_top_builddir\\)/hdf/src/\\.libs \\$\\(XDR_ADD\\)") ""))
+ #t)))))
(home-page "https://www.hdfgroup.org/products/hdf4/")
(synopsis
"Library and multi-object file format for storing and managing data")