summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-03-21 22:02:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-03-21 22:03:05 +0200
commit83a3464793f6aeb8d79e8561d50f0cdb6fb0068d (patch)
tree641e688afc2f68750c66b3ae29efd1ae18851543 /gnu/packages/maths.scm
parent8e4b7b75148e21bb5e800e64cf2dd51ad9f14286 (diff)
downloadguix-patches-83a3464793f6aeb8d79e8561d50f0cdb6fb0068d.tar
guix-patches-83a3464793f6aeb8d79e8561d50f0cdb6fb0068d.tar.gz
gnu: openblas: Add support for aarch64.
* gnu/packages/maths.scm (openblas)[arguments]: Mark aarch64 as substitutable, build for target ARMv8.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm8
1 files changed, 6 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ed13556cb4..166926da15 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Sou Bunnbu <iyzsong@gmail.com>
;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Fabian Harfert <fhmgufs@web.de>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
@@ -2243,7 +2243,8 @@ parts of it.")
,(let ((system (or (%current-target-system) (%current-system))))
(or (string-prefix? "x86_64" system)
(string-prefix? "i686" system)
- (string-prefix? "mips" system)))
+ (string-prefix? "mips" system)
+ (string-prefix? "aarch64" system)))
#:make-flags
(list (string-append "PREFIX=" (assoc-ref %outputs "out"))
"SHELL=bash"
@@ -2263,6 +2264,9 @@ parts of it.")
;; for Loongson cores are used.
((string-prefix? "mips" system)
'("TARGET=SICORTEX"))
+ ;; On aarch64 force the generic 'armv8-a' target
+ ((string-prefix? "aarch64" system)
+ '("TARGET=ARMV8"))
(else '()))))
;; no configure script
#:phases (alist-delete 'configure %standard-phases)))