summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-28 18:19:32 +0000
committerLudovic Courtès <ludo@gnu.org>2022-05-03 18:02:28 +0200
commit240b604eda8dd2b4d89ebfdfe19f98e029835816 (patch)
treecc40ab8c117659ddcac2574d6a124cb2b19f8542 /gnu/packages/maths.scm
parentd34f941c33a5a43099a4cec7e2e5675127077856 (diff)
downloadguix-patches-240b604eda8dd2b4d89ebfdfe19f98e029835816.tar
guix-patches-240b604eda8dd2b4d89ebfdfe19f98e029835816.tar.gz
gnu: dealii: Add SUNDIALS dependency.
* gnu/packages/maths.scm (dealii)[propagated-inputs]: Add sundials-5. Reformat list to clarify comment. (dealii-openmpi)[propagated-inputs]: Add sundials-openmpi-5. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d211c821e4..c4e1ef59a3 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5213,7 +5213,11 @@ A unique design feature of Trilinos is its focus on packages.")
;; Anyway, they are meant to be used at build time, so rather than adding
;; the interpreters here, any package depending on them should just add
;; the requisite interpreter to its native inputs.
- (list boost hdf5 suitesparse ; For UMFPACK.
+ (list boost
+ hdf5
+ suitesparse ; For UMFPACK.
+ ;; SUNDIALS 6.0.0 and later will be supported in deal.II 9.4.0.
+ sundials-5
tbb))
(arguments
`(#:build-type "DebugRelease" ; Supports only Debug, Release and DebugRelease.
@@ -5263,12 +5267,13 @@ in finite element programs.")
scalapack)))
(propagated-inputs
(modify-inputs (package-propagated-inputs dealii)
- (delete "hdf5")
+ (delete "hdf5" "sundials")
(prepend hdf5-parallel-openmpi
openmpi
p4est-openmpi
petsc-openmpi
slepc-openmpi
+ sundials-openmpi-5
trilinos-for-dealii-openmpi)))
(arguments
(substitute-keyword-arguments (package-arguments dealii)