summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-23 10:48:15 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-23 10:48:15 +0200
commite1b711b1f5f5b364f46aab45fb86707961b0613d (patch)
tree90588652bb708392be517f106147f522e7ae0c03 /gnu/packages/maths.scm
parent0f87bd0282d3014fc93409a9f3f6ada7bd2bbdd4 (diff)
downloadguix-patches-e1b711b1f5f5b364f46aab45fb86707961b0613d.tar
guix-patches-e1b711b1f5f5b364f46aab45fb86707961b0613d.tar.gz
gnu: maxima: Fix build.
Building with GCL is failing; build with SBCL instead. * gnu/packages/maths.scm (maxima)[inputs]: Replace gcl by sbcl. Add bash-minimal. [arguments]: Update 'configure-flags' and 'check' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index bd2d23c986..1f8b592ff7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Ivan Gankevich <i.gankevich@spbu.ru>
;;; Copyright © 2021 Jean-Baptiste Volatier <jbv@pm.me>
+;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -72,6 +73,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix git-download)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module ((guix build utils) #:select (alist-replace))
#:use-module (guix build-system cmake)
@@ -84,6 +86,7 @@
#:use-module (gnu packages audio)
#:use-module (gnu packages autotools)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages bison)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
@@ -3790,8 +3793,9 @@ to BMP, JPEG or PNG image formats.")
(patches (search-patches "maxima-defsystem-mkdir.patch"))))
(build-system gnu-build-system)
(inputs
- `(("gcl" ,gcl)
+ `(("bash" ,bash-minimal)
("gnuplot" ,gnuplot) ;for plots
+ ("sbcl" ,sbcl)
("sed" ,sed)
("tk" ,tk))) ;Tcl/Tk is used by 'xmaxima'
(native-inputs
@@ -3800,15 +3804,11 @@ to BMP, JPEG or PNG image formats.")
("python" ,python)))
(arguments
`(#:configure-flags
- (list "--enable-gcl"
- (string-append "--with-posix-shell="
- (assoc-ref %build-inputs "bash")
- "/bin/sh")
- (string-append "--with-wish="
- (assoc-ref %build-inputs "tk")
- "/bin/wish"
- (let ((v ,(package-version tk)))
- (string-take v (string-index-right v #\.)))))
+ ,#~(list "--enable-sbcl"
+ (string-append "--with-sbcl=" #$sbcl "/bin/sbcl")
+ (string-append "--with-posix-shell=" #$bash-minimal "/bin/sh")
+ (string-append "--with-wish=" #$tk "/bin/wish"
+ #$(version-major+minor (package-version tk))))
;; By default Maxima attempts to write temporary files to
;; '/tmp/nix-build-maxima-*', which won't exist at run time.
;; Work around that.
@@ -3845,7 +3845,7 @@ to BMP, JPEG or PNG image formats.")
(invoke "sh" "-c"
(string-append
"./maxima-local "
- "--lisp=gcl "
+ "--lisp=sbcl "
"--batch-string=\"run_testsuite();\" "
"| grep -q \"No unexpected errors found\""))))
;; Make sure the doc and emacs files are found in the