summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2021-08-20 13:54:35 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2021-08-20 14:10:49 +0200
commit361d4627ab8d0bea1e4bc07b13961ad34e8cd7e4 (patch)
tree746bd4a229d4a6e5ea03a15e921cc6950d2b2f35 /gnu/packages/maths.scm
parent979611d4ddb3e4fcd23b53ae05836750939dfdec (diff)
downloadguix-patches-361d4627ab8d0bea1e4bc07b13961ad34e8cd7e4.tar
guix-patches-361d4627ab8d0bea1e4bc07b13961ad34e8cd7e4.tar.gz
gnu: netcdf: Fix build.
* gnu/packages/maths.scm (netcdf)[arguments]: Fix regexp in 'patch-settings' phase.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 82ca9caff3..472f53720c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1697,7 +1697,7 @@ similar to MATLAB, GNU Octave or SciPy.")
;; filenames to avoid unnecessary references to the corresponding
;; store items.
(substitute* "libnetcdf.settings"
- (("(/gnu/store/)([a-Z0-9]*)" all prefix hash)
+ (("(/gnu/store/)([0-9A-Za-z]*)" all prefix hash)
(string-append prefix (string-take hash 10) "...")))
#t)))