summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-09-11 17:05:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-09-11 18:14:07 +0200
commit7be2b83102e477133cfdb9db6eac266da8c6140f (patch)
tree95b3a95bb6e86e1b85773a13e4e895c6321361a2 /gnu/packages/maths.scm
parent12a664a90e640cfdf83a2a6a85b33cb3c760f1ce (diff)
downloadguix-patches-7be2b83102e477133cfdb9db6eac266da8c6140f.tar
guix-patches-7be2b83102e477133cfdb9db6eac266da8c6140f.tar.gz
gnu: netcdf-parallel-openmpi: Allow compilation with GCC 10.
* gnu/packages/maths.scm (netcdf)[source]: Add 'modules' and 'snippet'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index a21c709405..b6fd5c9354 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1667,6 +1667,13 @@ similar to MATLAB, GNU Octave or SciPy.")
(sha256
(base32
"1a2fpp15a2rl1m50gcvvzd9y6bavl6vjf9zzf63sz5gdmq06yiqf"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Make sure this variable is defined only once. Failing to do so
+ ;; would break builds of 'netcdf-parallel-openmpi' with a
+ ;; multiple-definition link error with GCC 10.
+ '(substitute* "ncdump/ocprint.c"
+ (("^int ocdebug") "static int ocdebug")))
(patches (search-patches "netcdf-date-time.patch"))))
(build-system gnu-build-system)
(native-inputs