summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorKei Kebreau <kkebreau@posteo.net>2018-06-30 20:03:42 -0400
committerKei Kebreau <kkebreau@posteo.net>2018-06-30 20:05:58 -0400
commit7a3772b37478a3170e3703b31c9a60b764988c35 (patch)
treef552697b6dee8a6f4ba73c7dd851714a371d4d7c /gnu/packages/maths.scm
parent1314d349396e03c662a271e38d51691229293259 (diff)
downloadguix-patches-7a3772b37478a3170e3703b31c9a60b764988c35.tar
guix-patches-7a3772b37478a3170e3703b31c9a60b764988c35.tar.gz
gnu: qtoctave: Fix build for Qt 5.11.
* gnu/packages/maths.scm (qtoctave)[source]: Add patch. [native-inputs]: Add texlive. * gnu/packages/patches/qtoctave-qt-5.11-fix.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f3ada33e08..64b8887e48 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1400,12 +1400,18 @@ script files.")
(define-public qtoctave
(package (inherit octave)
(name "qtoctave")
+ (source (origin
+ (inherit (package-source octave))
+ (patches (append (origin-patches (package-source octave))
+ (search-patches
+ "qtoctave-qt-5.11-fix.patch")))))
(inputs
`(("qscintilla" ,qscintilla)
("qt" ,qtbase)
,@(package-inputs octave)))
(native-inputs
`(("qttools" , qttools) ;for lrelease
+ ("texlive" ,texlive) ;for texi2dvi
,@(package-native-inputs octave)))
(arguments
(substitute-keyword-arguments (package-arguments octave)