summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2016-04-05 18:48:02 +0200
committerAndreas Enge <andreas@enge.fr>2016-04-05 18:48:02 +0200
commitb146763a86812edc3de654403f70b8e699f2d090 (patch)
tree329d4da6c11e429dcdb6179211ba106cee73ec0c /gnu/packages/maths.scm
parent14e6520e2b9c47e7466be3cb5b3442ee9e6ceca2 (diff)
downloadguix-patches-b146763a86812edc3de654403f70b8e699f2d090.tar
guix-patches-b146763a86812edc3de654403f70b8e699f2d090.tar.gz
gnu: Add 4ti2.
* gnu/packages/maths.scm (4ti2): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d6b371ee81..1d879713ac 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
;;; Copyright © 2014 John Darrington <jmd@gnu.org>
;;; Copyright © 2014, 2015, 2016 Eric Bavier <bavier@member.fsf.org>
@@ -200,6 +200,33 @@ translator for the language. In addition to the C library, a stand-alone
LP/MIP solver is included in the package.")
(license license:gpl3+)))
+(define-public 4ti2
+ (package
+ (name "4ti2")
+ (version "1.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.4ti2.de/version_" version
+ "/4ti2-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1frix3rnm9ffr93alqzw4cavxbfpf524l8rfbmcpyhwd3n1km0yl"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("which" ,(@ (gnu packages base) which)))) ; for the tests
+ (inputs
+ `(("glpk" ,glpk)
+ ("gmp" ,gmp)))
+ (home-page "http://www.4ti2.de/")
+ (synopsis "Mathematical tool suite for problems on linear spaces")
+ (description
+ "4ti2 implements algorithms for solving algebraic, geometric and
+combinatorial problems on linear spaces. Among others, it solves systems
+of linear equations, computes extreme rays of polyhedral cones, solves
+integer programming problems and computes Markov bases for statistics.")
+ (license license:gpl2+)))
+
(define-public arpack-ng
(package
(name "arpack-ng")