summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-04-12 10:01:52 -0500
committerEric Bavier <bavier@member.fsf.org>2016-05-12 19:59:52 +0000
commit00775104ee652edbfe711568d8bbeb15a29920d2 (patch)
treed5e80d9773a3461bce6b4a9ad8a921abffeb7074 /gnu/packages/maths.scm
parentc8378eea10fa57c207550978dcf2998f3fc6b81c (diff)
downloadguix-patches-00775104ee652edbfe711568d8bbeb15a29920d2.tar
guix-patches-00775104ee652edbfe711568d8bbeb15a29920d2.tar.gz
gnu: Add h5check.
* gnu/packages/maths.scm (h5check): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index fce03ac5b8..76aecbc49e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -469,6 +469,26 @@ extremely large and complex data collections.")
#t))))))
(synopsis "Management suite for data with parallel IO support")))
+(define-public h5check
+ (package
+ (name "h5check")
+ (version "2.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.hdfgroup.org/ftp/HDF5/tools/"
+ "h5check/src/h5check-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1gm76jbwhz9adbxgn14zx8cj33dmjdr2g5xcy0m9c2gakp8w59kj"))))
+ (build-system gnu-build-system)
+ (inputs `(("hdf5" ,hdf5))) ;h5cc for tests
+ (home-page "https://www.hdfgroup.org/products/hdf5_tools/h5check.html")
+ (synopsis "HDF5 format checker")
+ (description "@code{h5check} is a validation tool for verifying that an
+HDF5 file is encoded according to the HDF File Format Specification.")
+ (license (license:x11-style "file://COPYING"))))
+
(define-public nlopt
(package
(name "nlopt")