summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-13 12:31:49 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-13 12:31:49 +0200
commit19bb999a50e5f9de8036bef4f3cba7144e978aaa (patch)
tree142ca6329d3a6fd077043e902da41edc4f052af5 /gnu/packages/maths.scm
parente90f1d5fa2ca206d0c900c9079c28db270f2e8d3 (diff)
downloadguix-patches-19bb999a50e5f9de8036bef4f3cba7144e978aaa.tar
guix-patches-19bb999a50e5f9de8036bef4f3cba7144e978aaa.tar.gz
gnu: openblas: Update to 0.3.1.
* gnu/packages/patches/openblas-fix-tests-i686.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it. * gnu/packages/maths.scm (openblas): Update to 0.3.1. [arguments, native-inputs]: Don't apply 'openblas-fix-tests-i686.patch'.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 2 insertions, 17 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1e0e1998db..0191c1ce1c 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2798,7 +2798,7 @@ parts of it.")
(define-public openblas
(package
(name "openblas")
- (version "0.3.0")
+ (version "0.3.1")
(source
(origin
(method url-fetch)
@@ -2807,7 +2807,7 @@ parts of it.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "14a9vyvp2k5zpd0axbnqk0d3khc1v3cck10nb5fj7d2sgn8490ky"))))
+ "1ly170gcdy0rgppfw1xn5yhjfzfqkka1gpggvvbls7138qbj7y9r"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -2846,16 +2846,6 @@ parts of it.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
- ;; Conditionally apply a patch on i686 to avoid rebuilding
- ;; all architectures. FIXME: This should be moved to the
- ;; (source (patches ...)) field in the next rebuild cycle.
- ,@(if (string-prefix? "i686" (or (%current-target-system)
- (%current-system)))
- `((add-after 'unpack 'fix-tests
- (lambda* (#:key inputs #:allow-other-keys)
- (invoke "patch" "-p1"
- "--input" (assoc-ref inputs "i686-fix-tests.patch")))))
- '())
(add-before 'build 'set-extralib
(lambda* (#:key inputs #:allow-other-keys)
;; Get libgfortran found when building in utest.
@@ -2867,11 +2857,6 @@ parts of it.")
`(("fortran-lib" ,gfortran "lib")))
(native-inputs
`(("cunit" ,cunit)
- ,@(if (string-prefix? "i686" (or (%current-target-system)
- (%current-system)))
- `(("i686-fix-tests.patch"
- ,(search-patch "openblas-fix-tests-i686.patch")))
- '())
("fortran" ,gfortran)
("perl" ,perl)))
(home-page "http://www.openblas.net/")