summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-02-16 23:01:56 +0100
committerLudovic Courtès <ludo@gnu.org>2014-02-16 23:35:37 +0100
commit7ee3f1a2089949870565582f306c5a40a08244d2 (patch)
treecca64c2ebc75f8355257124567ee988c9e6243fe /gnu/packages/maths.scm
parent436c95d9a73064d7884530928a6ebb331377a9e3 (diff)
downloadguix-patches-7ee3f1a2089949870565582f306c5a40a08244d2.tar
guix-patches-7ee3f1a2089949870565582f306c5a40a08244d2.tar.gz
gnu: Add hdf5.
* gnu/packages/maths.scm (hdf5): New variable. * gnu/packages/maths.scm (octave): New input hdf5. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index f5bd1d12d4..fe87e6d25a 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -236,6 +236,36 @@ plotting engine by third-party applications like Octave.")
(license (license:fsf-free
"http://gnuplot.cvs.sourceforge.net/gnuplot/gnuplot/Copyright"))))
+(define-public hdf5
+ (package
+ (name "hdf5")
+ (version "1.8.12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-"
+ version ".tar.bz2"))
+ (sha256
+ (base32 "0f9n0v3p3lwc7564791a39c6cn1d3dbrn7d1j3ikqsi27a8hy23d"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (alist-replace
+ 'configure
+ (lambda* (#:key target system outputs #:allow-other-keys #:rest args)
+ (let ((configure (assoc-ref %standard-phases 'configure)))
+ (substitute* "configure"
+ (("/bin/mv") "mv"))
+ (apply configure args)))
+ %standard-phases)))
+ (outputs '("out" "bin" "lib" "include"))
+ (home-page "http://www.hdfgroup.org")
+ (synopsis "Management suite for extremely large and complex data")
+ (description "HDF5 is a suite that makes possible the management of
+extremely large and complex data collections.")
+ (license (license:x11-style "http://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
+
+
;; For a fully featured Octave, users are strongly recommended also to install
;; the following packages: texinfo, less, ghostscript, gnuplot.
(define-public octave
@@ -260,6 +290,8 @@ plotting engine by third-party applications like Octave.")
("fltk" ,fltk)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
+ ("hdf5-lib" ,hdf5 "lib")
+ ("hdf5-include" ,hdf5 "include")
("libxft" ,libxft)
("mesa" ,mesa)
("zlib" ,zlib)))