summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-11-02 22:24:24 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-11-02 22:24:24 +0100
commitb4c22f25468cbb0b1644194381b25c795502bc16 (patch)
tree1f33dfd08b808a8e5c9518c78012b8b80e8d9016 /gnu/packages/maths.scm
parent5146f22b3b1615ed9d10796a0b1fffdf617138ef (diff)
parent77576be41f3b94c0f47457d338ddbbc8bf870ba9 (diff)
downloadguix-patches-b4c22f25468cbb0b1644194381b25c795502bc16.tar
guix-patches-b4c22f25468cbb0b1644194381b25c795502bc16.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c854a5a599..b0da39aee0 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -192,14 +192,28 @@ programming languages.")
(define-public units
(package
(name "units")
- (version "2.14")
+ (version "2.16")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/units/units-" version
".tar.gz"))
(sha256 (base32
- "1s421bxm36akjsy3qzg6da1d1g20gh094ac2slqxipgkh8yqjcwx"))))
+ "11hnp3gcmcc5kci2caxw4hs6m08h2mhqs3xzqq7iafx1ha2ggwyw"))))
(build-system gnu-build-system)
+ (inputs
+ `(("readline" ,readline)
+ ("python" ,python-wrapper) ;for 'units_cur' script
+ ("python-requests" ,python-requests)))
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-units_cur
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (wrap-program (string-append bin "/units_cur")
+ `("PYTHONPATH" ":" prefix
+ ,(search-path-as-string->list (getenv "PYTHONPATH"))))
+ #t))))))
(synopsis "Conversion between thousands of scales")
(description
"GNU Units converts numeric quantities between units of measure. It