summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:34:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-07-13 15:34:26 +0300
commitc5cfa23b9c00ccf6fc6d1b65fc30fe8fe73f5dda (patch)
treed62de514bd9ec81fcbb1d789ec301021c6df19fd /gnu/packages/maths.scm
parentcb78595fe3650057f258109c6599f4bae1d0e72e (diff)
downloadguix-patches-c5cfa23b9c00ccf6fc6d1b65fc30fe8fe73f5dda.tar
guix-patches-c5cfa23b9c00ccf6fc6d1b65fc30fe8fe73f5dda.tar.gz
gnu: gmsh: Simply downloading source logic.
* gnu/packages/maths.scm (gmsh)[source]: Use string-replace-substring.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index ff58b1df81..be3595fdce 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2266,8 +2266,7 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
(url "https://gitlab.onelab.info/gmsh/gmsh.git")
(commit
(string-append "gmsh_"
- (string-map (lambda (x) (if (eq? x #\.) #\_ x))
- version)))))
+ (string-replace-substring version "." "_")))))
(file-name (git-file-name name version))
(sha256
(base32 "07mi6ja3b9libgcdp2b4dwnkap1b9ha2wi2zdn9mhmwvp3g1pxhp"))