summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-03-14 17:36:07 +0100
committerAndreas Enge <andreas@enge.fr>2015-03-14 17:39:58 +0100
commitc12efc72cf27324f59f8543255697520fd82923e (patch)
treed3a79b49c642889982ade6a2bc7d4f257c625b1d /gnu/packages/maths.scm
parent1842a7cbc7c6738a18d4ff61e76215cdc2d71d82 (diff)
downloadguix-patches-c12efc72cf27324f59f8543255697520fd82923e.tar
guix-patches-c12efc72cf27324f59f8543255697520fd82923e.tar.gz
gnu: Add glm.
* gnu/packages/maths.scm (glm): New variable. Co-authored-by: John Darrington <john@darrington.wattle.id.au>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 8eda4bd0b6..52d5dd92a4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -66,7 +66,8 @@
#:use-module (gnu packages tcl)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages texlive)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages zip))
(define-public units
(package
@@ -1193,3 +1194,25 @@ cpufreq-selector -g performance -c N-1
where N is the number of cores of your CPU. Failure to do so will result in a
library with poor performance.")
(license license:bsd-3)))
+
+(define-public glm
+ (package
+ (name "glm")
+ (version "0.9.6.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/ogl-math/glm-"
+ version ".zip"))
+ (sha256
+ (base32
+ "1cnjmi033a16a95v6xfkr1bvfmkd26hzdjka8j1819hgn5b1nr8l"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "http://glm.g-truc.net")
+ (synopsis "OpenGL Mathematics library")
+ (description "OpenGL Mathematics (GLM) is a header-only C++ mathematics
+library for graphics software based on the OpenGL Shading Language (GLSL)
+specifications.")
+ (license license:expat)))