summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2019-09-12 16:12:31 +0100
committerPaul Garlick <pgarlick@tourbillion-technology.com>2019-09-12 16:21:31 +0100
commitabed5df7774a637a0104ca05254e8f97226d38d5 (patch)
tree9d98ec7a7c00299c5558f857eaadc4578f804081 /gnu/packages/maths.scm
parente2fb29b792cb9cf2416c6292ece56c09a89bdcc9 (diff)
downloadguix-patches-abed5df7774a637a0104ca05254e8f97226d38d5.tar
guix-patches-abed5df7774a637a0104ca05254e8f97226d38d5.tar.gz
gnu: gmsh: Fetch source from Git.
* gnu/packages/maths.scm (gmsh)[source]: Switch to GIT-FETCH.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index aa94d057cf..487f53ead1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -1717,11 +1717,16 @@ This is the certified version of the Open Cascade Technology (OCCT) library.")
(version "2.16.0")
(source
(origin
- (method url-fetch)
- (uri (string-append "http://gmsh.info/src/gmsh-"
- version "-source.tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.onelab.info/gmsh/gmsh.git")
+ (commit
+ (string-append "gmsh_"
+ (string-map (lambda (x) (if (eq? x #\.) #\_ x))
+ version)))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1slf0bfkwrcgn6296wb4qhbk4ahz6i4wfb10hnim08x05vrylag8"))
+ (base32 "08rq4jajwmlpivnm9yifz2jhaivnz065lnk0h2zv773nwl9wf162"))
(modules '((guix build utils)))
(snippet
;; Remove non-free METIS code