summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-25 16:25:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-25 17:24:58 +0300
commit0ffac75ece4f22a8595e19b8a375791e87d365aa (patch)
tree825137fc3d254ad48884313b39544b5dfe8dca16 /gnu/packages/maths.scm
parentd2a8b72b2ffe6ec743ddcdb82dfe4b96204b2b3a (diff)
downloadguix-patches-0ffac75ece4f22a8595e19b8a375791e87d365aa.tar
guix-patches-0ffac75ece4f22a8595e19b8a375791e87d365aa.tar.gz
gnu: qhull: Build position independent.
* gnu/packages/maths.scm (qhull)[arguments]: Add configure-flag to build code position independent.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d0ca2f4647..3d7248417b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -248,7 +248,8 @@ programming languages.")
"0zlbhg0lb6j60188c2xhcrvviskr079552icjldqhy1jhgmxghmm"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DLINK_APPS_SHARED=ON")))
+ `(#:configure-flags '("-DLINK_APPS_SHARED=ON"
+ "-DCMAKE_POSITION_INDEPENDENT_CODE=ON")))
(synopsis "Calculate convex hulls and related structures")
(description
"@code{Qhull} computes the convex hull, Delaunay triangulation, Voronoi