summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-06 01:06:06 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-11-11 12:18:36 -0500
commit9e497f44ba8104b6b4743e72cb041c8e15586a83 (patch)
treef28a2cdaf632d4096672461921206bc3953db3f9 /gnu/packages/maths.scm
parent59ca8d6483aedf3df0f112111d7747e47182bee2 (diff)
downloadguix-patches-9e497f44ba8104b6b4743e72cb041c8e15586a83.tar
guix-patches-9e497f44ba8104b6b4743e72cb041c8e15586a83.tar.gz
gnu: openblas: Add support for older x86 processors.
Fixes <https://issues.guix.gnu.org/51452>. * gnu/packages/maths.scm (openblas)[make-flags]: Make the x86_64, i686, powerpc64le and aarch64 architectures share the same flags; this causes the DYNAMIC_OLDER=1 to be added for all of them and TARGET=GENERIC to be added for the x86_64 and i686 architectures.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 2f0ef52613..45c28106e7 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -4444,13 +4444,13 @@ parts of it.")
,@(let ((system (or (%current-target-system) (%current-system))))
(cond
((or (string-prefix? "x86_64" system)
- (string-prefix? "i686" system))
- '("DYNAMIC_ARCH=1"))
- ;; On some of these architectures the CPU can't be detected.
- ((or (string-prefix? "powerpc64le" system)
+ (string-prefix? "i686" system)
+ (string-prefix? "powerpc64le" system)
(string-prefix? "aarch64" system))
- '("DYNAMIC_ARCH=1"
- "TARGET=GENERIC"))
+ ;; Dynamic older enables a few extra CPU architectures that
+ ;; were released before 2010.
+ '("DYNAMIC_ARCH=1" "DYNAMIC_OLDER=1" "TARGET=GENERIC"))
+ ;; On some of these architectures the CPU can't be detected.
;; On MIPS we force the "SICORTEX" TARGET, as for the other
;; two available MIPS targets special extended instructions
;; for Loongson cores are used.